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What is the NAACCR Record Layout?What is the NAACCR Record Layout?

�� File format used to exchange (most) cancer File format used to exchange (most) cancer 
registry data in the U.S. and Canadaregistry data in the U.S. and Canada
–– Some path lab data being exchanged in HL7 Some path lab data being exchanged in HL7 

and pipeand pipe--delimited formatsdelimited formats

�� “Flat” text file, one patient record per line“Flat” text file, one patient record per line
�� FixedFixed--field width (fields are not delimited)field width (fields are not delimited)
�� Managed by NAACCR’s IT & Uniform Managed by NAACCR’s IT & Uniform 

Data Standards (UDS) CommitteesData Standards (UDS) Committees
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What is the NAACCR Record Layout?What is the NAACCR Record Layout?

�� Most registries currently using v11.3, but Most registries currently using v11.3, but 
planning to transition to v12 around now or planning to transition to v12 around now or 
within the next few monthswithin the next few months

�� v11.3 is 377 active data items plus v11.3 is 377 active data items plus 
30 “reserved” & 64 retired data items30 “reserved” & 64 retired data items

�� v11.3 is 6694 characters per linev11.3 is 6694 characters per line
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What is the NAACCR Record Layout?What is the NAACCR Record Layout?

�� Line length has increased slowly with time Line length has increased slowly with time 
as number of data items has increased, until as number of data items has increased, until 
recently…recently…
–– v1.0v1.0--v4.0  (1994v4.0  (1994--1995)  =  5300 characters1995)  =  5300 characters
–– v5.0v5.0--v9.1  (1996v9.1  (1996--2002)  =  5966 characters2002)  =  5966 characters
–– v10.0v10.0--v11.3  (2003v11.3  (2003--2009)  =  6694 characters2009)  =  6694 characters
–– v12.0  (2010)  = 22,824 charactersv12.0  (2010)  = 22,824 characters
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What’s New With v12?What’s New With v12?

�� All date fields changedAll date fields changed
–– Now in YYYYMMDD formatNow in YYYYMMDD format
–– Only valid years (no 9s, 8s, or 0s)Only valid years (no 9s, 8s, or 0s)
–– Blanks indicate unknown day, month, yearBlanks indicate unknown day, month, year
–– New date flags indicate “Flavor of Null”New date flags indicate “Flavor of Null”
–– Only affects how dates are Only affects how dates are exchangedexchangedas part of as part of 

Record Layout, not how Record Layout, not how storedstoredin the registry in the registry 
databasedatabase
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What’s New With v12?What’s New With v12?

�� 126 new data items (incl. 26 date flags)126 new data items (incl. 26 date flags)
�� 14 newly retired data items14 newly retired data items
�� Total of 489 active data items, & 15 “reserved”Total of 489 active data items, & 15 “reserved”
�� Most text fields expanded Most text fields expanded –– 16 fields now have 16 fields now have 

1000 characters (mostly Dx & Tx text)1000 characters (mostly Dx & Tx text)
�� As a result of these changes, no. of characters As a result of these changes, no. of characters 

per line more than tripled to 22,824 !!!per line more than tripled to 22,824 !!!
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New Challenges for the Registry Data Analyst…New Challenges for the Registry Data Analyst…
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New Date FormatNew Date Format

�� All computer operations involving dates All computer operations involving dates 
(calculations, queries, etc.) using the (calculations, queries, etc.) using the 
NAACCR record layout must be reviewed NAACCR record layout must be reviewed 
and possibly revisedand possibly revised
–– Old operations expecting MMDDYYYY, Old operations expecting MMDDYYYY, 

not YYYYMMDDnot YYYYMMDD
–– How do you handle blanks instead of 9s?How do you handle blanks instead of 9s?

»»20100715 vs. 201007 vs. 2010 vs. “  ”20100715 vs. 201007 vs. 2010 vs. “  ”
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Longer Line LengthLonger Line Length

�� Many text editors cannot edit and save 22,824 Many text editors cannot edit and save 22,824 
characters per linecharacters per line

�� Popular editors that can’t properly edit v12 files:Popular editors that can’t properly edit v12 files:
–– Programmer’s File Editor Programmer’s File Editor (freeware) truncates each (freeware) truncates each 

line at 16,385 charactersline at 16,385 characters
–– UltraEditUltraEdit ($60) wraps line at 4096 characters ($60) wraps line at 4096 characters ----

each line is displayed as six separate lines, so each line is displayed as six separate lines, so 
editing is difficultediting is difficult
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Text Editors for v12 FilesText Editors for v12 Files

�� Notepad++Notepad++
–– Download from Download from 

http://notepadhttp://notepad--plus.sourceforge.net/uk/site.htmplus.sourceforge.net/uk/site.htm

–– FreewareFreeware

�� TextPadTextPad
–– Download from http://www.textpad.comDownload from http://www.textpad.com
–– Available for purchase for about $25Available for purchase for about $25
–– Free trial version available for downloadFree trial version available for download
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Text Editor vs. DatabaseText Editor vs. Database

�� Text Editor good for limited operationsText Editor good for limited operations
–– Counting rowsCounting rows
–– Viewing contents of the fileViewing contents of the file
–– Some minimal QC, need to preserve column Some minimal QC, need to preserve column 

spacingspacing
–– Can do some column operations using macro Can do some column operations using macro 

recordingsrecordings
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Text Editor vs. DatabaseText Editor vs. Database

�� Database good for advanced operationsDatabase good for advanced operations
–– Rows can be sorted by any columnRows can be sorted by any column
–– Selection queries allow viewing of a subset Selection queries allow viewing of a subset 

of the rows and subset of the columnsof the rows and subset of the columns
–– Update queries can do global changes to all Update queries can do global changes to all 

rows or selected rowsrows or selected rows
–– Can perform calculationsCan perform calculations
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Importing a v12 File into MS AccessImporting a v12 File into MS Access

�� File>Get External Data>Import>Text FilesFile>Get External Data>Import>Text Files
�� Click on “Advanced” command buttonClick on “Advanced” command button
�� Click on “Specs” command buttonClick on “Specs” command button
�� Choose the NAACCR v12 import/export Choose the NAACCR v12 import/export 

specificationspecification
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What,What, you don’t have NAACCR v12 import specs?you don’t have NAACCR v12 import specs?
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Creating v12 Import SpecsCreating v12 Import Specs

�� 489 data items, but 255 columns max, so need to 489 data items, but 255 columns max, so need to 
combine data itemscombine data items

�� Refer to NAACCR Standards Vol 2, Refer to NAACCR Standards Vol 2, 
Data Dictionary, Ch 7: Record Layout TableData Dictionary, Ch 7: Record Layout Table

�� Start entering information into the fixed width Start entering information into the fixed width 
Specs tableSpecs table

�� Make large text fields (>255 char) into memo fieldsMake large text fields (>255 char) into memo fields
�� And after several hours…And after several hours…
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OR… Just call me and I’ll send you my import specs!OR… Just call me and I’ll send you my import specs!

(Conference theme is “Collaboration”)(Conference theme is “Collaboration”)
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Congratulations!Congratulations!

You can now import v12 files You can now import v12 files 
into MS Accessinto MS Access
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Another Option…Another Option…

�� I want to easily access all 489 data itemsI want to easily access all 489 data items
�� Then ODBC Linkage may be your solution!Then ODBC Linkage may be your solution!
�� “Open Data Base Connectivity”“Open Data Base Connectivity”
�� Dynamic access of one database’s tables Dynamic access of one database’s tables 

from a second databasefrom a second database
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Example ODBC Linkage:Example ODBC Linkage:

MS Access to SQL ServerMS Access to SQL Server
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Create Empty SQL DatabaseCreate Empty SQL Database

�� Create an empty MS SQL database for your Create an empty MS SQL database for your 
registry’s database softwareregistry’s database software

�� Connect your empty database to SQL Server Connect your empty database to SQL Server 
using Management Studiousing Management Studio

�� Run your registry database software and Run your registry database software and 
connect to the new empty databaseconnect to the new empty database
–– May involve swapping database names in May involve swapping database names in 

Management StudioManagement Studio
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Import DataImport Data

�� Import the data file using software’s import Import the data file using software’s import 
specs for NAACCR v12 Record Layoutspecs for NAACCR v12 Record Layout

�� Put records in a “holding area” (Pending, Put records in a “holding area” (Pending, 
Suspense, etc)Suspense, etc)
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Create Data Source Name (DSN)Create Data Source Name (DSN)

�� Start>Programs>Administrative Tools>Start>Programs>Administrative Tools>
Data Sources (ODBC)>File DSN tabData Sources (ODBC)>File DSN tab

�� Create a File DSN for your SQL databaseCreate a File DSN for your SQL database
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Create ODBC LinkageCreate ODBC Linkage

�� In MS Access, File>Get External Data>In MS Access, File>Get External Data>
Link Tables>ODBC DatabasesLink Tables>ODBC Databases

�� Select your new File DSN as your data sourceSelect your new File DSN as your data source
�� Select your database tables, remember to Select your database tables, remember to 

check box to “Save password”check box to “Save password”
�� Select Unique Record ID fieldSelect Unique Record ID field
�� Linked tables will appear with special arrow Linked tables will appear with special arrow 

& globe symbols to the left of the name& globe symbols to the left of the name
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Export RecordsExport Records

�� When all operations are completed, export When all operations are completed, export 
records from database to text file using records from database to text file using 
software’s export specs in NAACCR software’s export specs in NAACCR 
Record Layout v12Record Layout v12

�� Delete records in databaseDelete records in database
�� Reconnect your registry database software Reconnect your registry database software 

to your central registry databaseto your central registry database
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In SummaryIn Summary

�� Data Analyst has new challenges in Data Analyst has new challenges in 
working with NAACCR v12 Record Layoutworking with NAACCR v12 Record Layout

�� Can edit files with Notepad++ or TextPadCan edit files with Notepad++ or TextPad
�� Can import files into MS Access for editing, Can import files into MS Access for editing, 

but have to combine some data itemsbut have to combine some data items
�� Can do ODBC linkage to a SQL database Can do ODBC linkage to a SQL database 

for editing of all data itemsfor editing of all data items
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Thanks very much!Thanks very much!


